Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
rossiOffline
Post subject: Problem Installing nouveau  PostPosted: 23.02.2012, 18:19



Joined: 2010-09-13
Posts: 35
Location: New York City
Status: Offline
Hello:

I am running the following:
      Code:

Linux siduxbox 3.2-7.slh.2-aptosid-686 #1 SMP PREEMPT Wed Feb 22 17:08:29 UTC 2012 i686 GNU/Linux

01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce Go 7600] (rev a1) (prog-if 00 [VGA controller])

I am having a problem installing nouveau.

I followed the directions in

      Code:
http://aptosid.com/index.php?module=wikula&tag=GoNvidia


as closely as possible to convert to nouveau from nvidia drivers.

But, something is wrong. I get a desktop but with a vga screen, and it's terrible. There is extremely limited functionality.

I think that

      Quote:
If using KDE, in System Settings turn desktop effects composite type to "Xrender" (keeping OpenGL there might lead to KDE not starting with certain desktop effects active).


is happing too. Since, I don't have any kde functionality, I don't know how to execute the "Xrender" command.

Here are some problems:

1)
      Quote:

Remove all vga=xxx and xmodule=xxx entries from /etc/default/grub, and do update-grub.
Reboot.


But, here are the contents of the
      Code:

/etc/default/grub

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset nouveau.modeset=0"
GRUB_CMDLINE_LINUX="vga=792 splash quiet"


Obviously the
      Code:
GRUB_CMDLINE_LINUX="vga=792 splash quiet"
line leads to the wierd desk top. But how to change this? The instructions say to remove the vga entry. If I do that, the system boots with no X and no desktop. The instructions do not say what to have in here. Trust me, I changed this entry, and I got into a situation where the system would boot and shut down immdeiately.

I had to use a rescue disk with chroot to fix this entry and run
      Code:
update-grub
to fix things.

I need help here.

2) Do I need an
      Code:
/etc/X11/xorg.conf
file with nouveau?

In the xorg.conf file, there is an entry which used to have "nvidia", and I changed it to "nouveau".
      Code:

Section "Device"
    Identifier     "Device0"
    Driver         "nouveau"
        Option      "Coolbits"  "1"
        Option      "AddARGBGLXVisuals" "true"
        Option      "TripleBuffer"      "false"
    VendorName     "NVIDIA Corporation"
EndSection


This doesn't work. I must comment out the line that has
      Code:
Driver "nouveau"
, otherwise I get no X and no desktop.

Why is this?

The nouveau Wiki indicates that I can have an entry such as the above.

I need help here too.

3) Full disclosure:
      Quote:

WARNING: Your results will vary if you ever have used the installer from Nvidia (the .run file) or other 3rd party scripts/packages, instead of using proper Debian packages!


I did do this.

But, ALL my dist upgrades were done with
      Code:

apt-get update
apt-get dist-upgrade


Can someone please help with this?

Kind regards,

Angelo[/quote]
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
x-un-i
Post subject: RE: Problem Installing nouveau  PostPosted: 23.02.2012, 18:55
Team Member


Joined: 2010-08-26
Posts: 170

you have deinstalled all the nVidia things?

if yes did you tried to start X without an xorg.conf at all?

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
slhOffline
Post subject: RE: Problem Installing nouveau  PostPosted: 23.02.2012, 18:59



Joined: 2010-08-25
Posts: 689

Status: Offline
nouveau (just like intel or radeon) requires modesetting to be enabled, so drop "nomodeset", "nouveau.modeset=0" and "vga=792" from /etc/default/grub with your favourite editor (while you're at it, drop "splash" as well, which has no functionality either) and run update-grub. Furthermore delete /etc/X11/xorg.conf and make sure that nouveau is not blacklisted in /etc/modprobe.d/ (delete any files trying to do so). Make sure that all non-free nvidia packages are purged from your system, because they replace the proper mesa opengl libraries with their own (incompatible) implementation.
 
 View user's profile Send private message  
Reply with quote Back to top
rossiOffline
Post subject: Re: RE: Problem Installing nouveau  PostPosted: 24.02.2012, 15:01



Joined: 2010-09-13
Posts: 35
Location: New York City
Status: Offline
Dear slh and x-un-i:

      x-un-i wrote:
you have deinstalled all the nVidia things?

if yes did you tried to start X without an xorg.conf at all?


Thank you for your reply.

When I use the command

[code]dpkg -l | grep -i nvidia[code]

I don't get any hits. I can be sure, but I think all nvidia stuff is purged.

Right now, I am stymied. I get a desktop, but it is severly constrained. One thing I need is the icon to configure a display. It's gone. I try a testby plugging in a second monitor, and I get nothing.

I need this feature for Monday to plugin an overhead projector to teach a class.

Most of kde functionality is not there.

Thank you again, and if there are more suggestion for me to try, please let me know.

Note to n-un-i: your suggestions did not help. when I implemented them, I got random characters on the screen and no display. Thank you for your help too.

Kind regards,

Angelo
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
hubiOffline
Post subject: RE: Re: RE: Problem Installing nouveau  PostPosted: 24.02.2012, 15:36
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
Try not to use any device section in your xorg.conf. It's simply not needed.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
x-un-i
Post subject: Re: RE: Problem Installing nouveau  PostPosted: 24.02.2012, 17:27
Team Member


Joined: 2010-08-26
Posts: 170

      slh wrote:
nouveau (just like intel or radeon) requires modesetting to be enabled, so drop "nomodeset", "nouveau.modeset=0" and "vga=792" from /etc/default/grub with your favourite editor (while you're at it, drop "splash" as well, which has no functionality either) and run update-grub. Furthermore delete /etc/X11/xorg.conf and make sure that nouveau is not blacklisted in /etc/modprobe.d/ (delete any files trying to do so). Make sure that all non-free nvidia packages are purged from your system, because they replace the proper mesa opengl libraries with their own (incompatible) implementation.


Did you follow this advice?

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
rossiOffline
Post subject: Re: RE: Problem Installing nouveau  PostPosted: 25.02.2012, 19:12



Joined: 2010-09-13
Posts: 35
Location: New York City
Status: Offline
[quote="x-un-i"]
      slh wrote:
nouveau (just like intel or radeon) requires modesetting to be enabled, so drop "nomodeset", "nouveau.modeset=0" and "vga=792" from /etc/default/grub with your favourite editor (while you're at it, drop "splash" as well, which has no functionality either) and run update-grub. Furthermore delete /etc/X11/xorg.conf and make sure that nouveau is not blacklisted in /etc/modprobe.d/ (delete any files trying to do so). Make sure that all non-free nvidia packages are purged from your system, because they replace the proper mesa opengl libraries with their own (incompatible) implementation.


Did you follow this advice?

Hello:

Here is what I have so far:

      Code:

root@siduxbox:~# ls /etc/X11
app-defaults             xorg.conf.backup2
cursors                  xorg.conf-bu-2012-02-22-17:03:35
default-display-manager  xorg.conf-bu-rossi
fluxbox                  Xreset
fonts                    Xreset.d
mwm                      Xresources
rgb.txt                  Xsession
X                        Xsession.d
xinit                    Xsession.options
xkb                      XvMCConfig
xorg.conf.backup         Xwrapper.config
xorg.conf.backup1

so no xorg.conf file.

      Code:

root@siduxbox:~# dpkg -l | grep nvidia
root@siduxbox:~#

so it seems as if the nvidia stuff is purged.

      Code:

root@siduxbox:~# ls /etc/modprobe.d/
aliases.conf              kms-sg-blacklist.conf
alsa-base-blacklist.conf  libpisock9.conf
alsa-base.conf            linux-sound-base_noOSS.conf
dkms.conf                 oss-compat.conf
fbdev-blacklist.conf      radeon-kms.conf
i915-kms.conf             ueagle-atm.conf
root@siduxbox:~# cd /etc/modprobe.d/
root@siduxbox:/etc/modprobe.d# grep -i nouveau *
kms-sg-blacklist.conf:# blacklist nouveau

so I commented out the black listing of nouveau.
      Code:

root@siduxbox:/etc/modprobe.d# locate nvidia
/lib/modules/3.2-7.slh.1-aptosid-686/kernel/drivers/char/agp/nvidia-agp.ko
/lib/modules/3.2-7.slh.1-aptosid-686/kernel/drivers/net/ethernet/nvidia
/lib/modules/3.2-7.slh.1-aptosid-686/kernel/drivers/net/ethernet/nvidia/forcedeth.ko
/lib/modules/3.2-7.slh.2-aptosid-686/kernel/drivers/char/agp/nvidia-agp.ko
/lib/modules/3.2-7.slh.2-aptosid-686/kernel/drivers/net/ethernet/nvidia
/lib/modules/3.2-7.slh.2-aptosid-686/kernel/drivers/net/ethernet/nvidia/forcedeth.ko
/usr/lib/libkwinnvidiahack.so.4
/usr/lib/libkwinnvidiahack.so.4.6.0
/usr/share/hal/fdi/information/10freedesktop/21-video-quirk-nvidia.fdi
/usr/share/modass/packages/nvidia-kernel-source
/usr/src/linux-headers-3.2-7.slh.1-aptosid-686/drivers/net/ethernet/nvidia
/usr/src/linux-headers-3.2-7.slh.1-aptosid-686/drivers/net/ethernet/nvidia/Kconfig
/usr/src/linux-headers-3.2-7.slh.1-aptosid-686/drivers/net/ethernet/nvidia/Makefile
/usr/src/linux-headers-3.2-7.slh.1-aptosid-686/drivers/video/nvidia
/usr/src/linux-headers-3.2-7.slh.1-aptosid-686/drivers/video/nvidia/Makefile
/usr/src/linux-headers-3.2-7.slh.1-aptosid-686/include/config/agp/nvidia.h
/usr/src/linux-headers-3.2-7.slh.1-aptosid-686/include/config/net/vendor/nvidia.h
/usr/src/linux-headers-3.2-7.slh.2-aptosid-686/drivers/net/ethernet/nvidia
/usr/src/linux-headers-3.2-7.slh.2-aptosid-686/drivers/net/ethernet/nvidia/Kconfig
/usr/src/linux-headers-3.2-7.slh.2-aptosid-686/drivers/net/ethernet/nvidia/Makefile
/usr/src/linux-headers-3.2-7.slh.2-aptosid-686/drivers/video/nvidia
/usr/src/linux-headers-3.2-7.slh.2-aptosid-686/drivers/video/nvidia/Makefile
/usr/src/linux-headers-3.2-7.slh.2-aptosid-686/include/config/agp/nvidia.h
/usr/src/linux-headers-3.2-7.slh.2-aptosid-686/include/config/net/vendor/nvidia.h
/var/log/nvidia-installer.log

Is there anything found with the locate command that I should take care of?

Now the /etc/default/grub file:
      Code:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset nouveau.modeset=0"
GRUB_CMDLINE_LINUX="vga=792 splash quiet"

This is way the /etc/fault/grub file now stands.
1) If
      Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
and if
      Code:
GRUB_CMDLINE_LINUX="quiet"
, I get a blank screen with nothing there. The initial screen before X attempt says something like
      Quote:
failed to find nouveau init table.
.
2) With
      Code:
GRUB_CMDLINE_LINUX_DEFAULT
the same as above but
      Code:
GRUB_CMDLINE_LINUX="splash quiet"
, the system fails to generate a desktop and X.
3) With
      Code:
GRUB_CMDLINE_LINUX_DEFAULT
the same as above but
      Code:
GRUB_CMDLINE_LINUX="vga splash quiet"
, the system windows have random unreadable characters, but it does generate a desktop and X with severely limited KDE.
4)With the system exactly as above, system windows are fine, and a desktop with X is generated, but again with a severly limited KDE.

That is where it stands now.

I appreciate your help and patience.

Warm regards,

Angelo
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
x-un-i
Post subject: RE: Re: RE: Problem Installing nouveau  PostPosted: 25.02.2012, 19:28
Team Member


Joined: 2010-08-26
Posts: 170

do you have a recent aptosid iso ?

i'm rather curious which resolution you get when you boot it.

can you also provide us with the output of infobash -v3 command run in a terminal?

_________________
Why do strong arms fatigue themselves with frivolous dumbbells?
To dig a vineyard is worthier exercise for men.
Marcus Valerius Martialis, römischer Satiriker und Epigrammdichter

Será que o diabo perdeu a virgindade?
 
 View user's profile Send private message  
Reply with quote Back to top
rossiOffline
Post subject: Re: RE: Re: RE: Problem Installing nouveau  PostPosted: 25.02.2012, 19:50



Joined: 2010-09-13
Posts: 35
Location: New York City
Status: Offline
      x-un-i wrote:
do you have a recent aptosid iso ?

i'm rather curious which resolution you get when you boot it.

can you also provide us with the output of infobash -v3 command run in a terminal?


No I don't have a recent one, but I could generate one. Would the nouveau drivers activate in an interactive boot?

      Code:

root@siduxbox:~# infobash -v3
Host/Kernel/OS  "siduxbox" running Linux 3.2-7.slh.2-aptosid-686 i686 [ sidux 2009-01 Ουρανός - kde-full - (200902151348) ]
CPU Info        2x Intel Core2 T7400 @ 4096 KB cache flags( sse3 ht lm vmx ) clocked at [ 2167.000 MHz ]                                                                                     
Videocard       nVidia G73 [GeForce Go 7600]     [  ]                                         
Network cards   Realtek RTL8111/8168B PCI Express Gigabit                                     
                Intel PRO/Wireless 3945ABG [Golan]                                             
Processes 126 | Uptime 5min | Memory 317.0/2024.7MB | HDD Hitachi HTS54121 Size 100GB (0%used) | Client Shell | Infobash v3.41           


With the nvidia drivers, I was getting better resolution than the vga provides.

Regards,

Angelo
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
rossiOffline
Post subject: RE: Re: RE: Re: RE: Problem Installing nouveau  PostPosted: 25.02.2012, 19:52



Joined: 2010-09-13
Posts: 35
Location: New York City
Status: Offline
      Code:

rossiar@siduxbox ~/ $ infobash -v3
Host/Kernel/OS  "siduxbox" running Linux 3.2-7.slh.2-aptosid-686 i686 [ sidux 2009-01 Ουρανός - kde-full - (200902151348) ]
CPU Info        2x Intel Core2 T7400 @ 4096 KB cache flags( sse3 ht lm vmx ) clocked at [ 1333.000 MHz ]
Videocard       nVidia G73 [GeForce Go 7600]  X.Org 1.11.3.901  [ 1024x768@61.0hz ]
Network cards   Realtek RTL8111/8168B PCI Express Gigabit
                Intel PRO/Wireless 3945ABG [Golan]
Processes 121 | Uptime 12min | Memory 327.8/2024.7MB | HDD Hitachi HTS54121 Size 100GB (0%used) | GLX Renderer Software Rasterizer | GLX Version Yes | Client Shell | Infobash v3.41


gives the resolution as a normal user.
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
towoOffline
Post subject: RE: Re: RE: Re: RE: Problem Installing nouveau  PostPosted: 25.02.2012, 20:02



Joined: 2010-09-13
Posts: 496
Location: Pößneck / Thüringen
Status: Offline
That's not nouveau, that's vesa, check your /var/log/Xorg.0.log
 
 View user's profile Send private message  
Reply with quote Back to top
rossiOffline
Post subject: Re: RE: Re: RE: Re: RE: Problem Installing nouveau  PostPosted: 25.02.2012, 20:23



Joined: 2010-09-13
Posts: 35
Location: New York City
Status: Offline
      towo wrote:
That's not nouveau, that's vesa, check your /var/log/Xorg.0.log


OK. I will check this.

But, how did this happen? How can I stop it from happening? Why didn't it pick up the nouveau drivers. I really appreciate your telling me the potential problem, but can you help to tell me the piece of logic I am missing in fixing this problem? I don't want vga, and I don't want vesa. I want nouveau, but I am having problems fixing this.

Thank you in advance for any help you can provide.

Kind regards,

Angelo
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
hubiOffline
Post subject: RE: Re: RE: Re: RE: Re: RE: Problem Installing nouveau  PostPosted: 25.02.2012, 22:27
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
What about the parameters in /etc/default/grub? nomodeset and vga?

I use a Nvidia 7600 card with nouveau and it works. There is no xorg.conf and there are no kernel parameters set.

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
WillamKOffline
Post subject: RE: Re: RE: Re: RE: Re: RE: Problem Installing nouveau  PostPosted: 28.02.2012, 05:11



Joined: 2012-02-17
Posts: 12
Location: Miami
Status: Offline
I need some information Can you give me some information about installing Method
 
 View user's profile Send private message  
Reply with quote Back to top
hubiOffline
Post subject: Re: RE: Re: RE: Re: RE: Re: RE: Problem Installing nouveau  PostPosted: 28.02.2012, 05:40
Moderator


Joined: 2010-09-11
Posts: 228
Location: Vienna (AT)
Status: Offline
      WillamK wrote:
I need some information Can you give me some information about installing Method

I followed these instructions:
http://aptosid.com/index.php?module=wik ... g=GoNvidia

hubi

_________________
Tilos Rádió Budapest
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio