Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
wkauzOffline
Post subject: "Phone hung up" with wvdial and Ericsson F5521wg  PostPosted: 10.01.2013, 14:57



Joined: 2010-09-13
Posts: 16
Location: Saarbrücken/Germany
Status: Offline
Hallo!

Think Pad T420 / Thanatos 64amd


root@aptosidbox:/# wvdial pin
--> WvDial: Internet dialer version 1.61
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CPIN=7704
AT+CPIN=####
ERROR
--> Bad init string.
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK


and:


root@aptosidbox:/# wvdial umts
--> WvDial: Internet dialer version 1.61
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","fonic.de"
AT+CGDCONT=1,"IP","fonic.de"
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
CONNECT
~[7f]}#@!}!}!} }=}#}%B#}%}(}"}'}"}!}$}%\}"}&} } } } }%}&,77}(.[12]~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Thu Jan 10 19:50:44 2013
--> Pid of pppd: 4361
--> Using interface ppp0
--> Disconnecting at Thu Jan 10 19:50:45 2013
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK



I don't know what is wrong.

My wvdial.conf:


[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttyACM0
ISDN = 0
; Phone = <Target Phone Number>
; Password = <Your Password>
; Username = <Your Login Name>

[Dialer pin]
Init3 = AT+CPIN=####

[Dialer umts]
Carrier Check = no
Init4 = AT+CGDCONT=1,"IP","fonic.de"
Stupid Mode = 1
Phone = *99su***1#
Dialer Command = ATD
Dial Attemps = 2
Username = egal
Password = egal


Has someone any idea?

Thanks
wkauz
 
 View user's profile Send private message  
Reply with quote Back to top
wkauzOffline
Post subject: RE: "Phone hung up" with wvdial and Ericsson F5521  PostPosted: 10.01.2013, 15:02



Joined: 2010-09-13
Posts: 16
Location: Saarbrücken/Germany
Status: Offline
Sorry!

Naturely by "Phone" is wroten *99***1#

Thanks
wkauz
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject: RE: "Phone hung up" with wvdial and Ericsson F5521  PostPosted: 11.01.2013, 12:49
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
Your wvdail.conf looks like a mess and e.g. "Dailer pin" lacks info lik Phone, Username, Password, … that is not supposed to work I guess.

How about setting up first one dailer and then the other?
You are best of Googling^WDuckDuckGoing for your provider and wvdail, that should lead you to a working config for wvdail.

btw: The error message says you should log at /var/log/messages – doing this might be interesting, too, if the problem presists. (It is the file behind 'dmesg', so it will contain a lot of stuff and you are probably only interested in the last few lines if at all).

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
wkauzOffline
Post subject:   PostPosted: 12.01.2013, 15:46



Joined: 2010-09-13
Posts: 16
Location: Saarbrücken/Germany
Status: Offline
Hallo DonKult:

Thanks a lot for your systematik answer.

After googling this:

http://www.telespiegel.de/handy/gprs-um ... sdaten.php


I changed my wvdial.conf like this (and after the guidline in the aptosidWiki):



      Quote:
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Baud = 460800
New PPPD = yes
Modem = /dev/ttyACM0
ISDN = 0
;Phone = <Phonenumber>
;Password = <Your Password>
;Username = <Your Login Name>

[Dialer pin]
Init3 = AT+CPIN=####

[Dialer umts]
Carrier Check = no
Init4 = AT+CGDCONT=1,"IP","pinternet.interkom.de"
Stupid Mode = 1
Phone = *99#
Dialer Command = ATD
Dial Attemps = 2
Username = nowhere
Password = 112233



In between, I chanched the position of [Dialer pin] to init 4/[Dialer umts] to init3.
Always the same:


      Quote:
root@aptosidbox:/# wvdial umts
--> WvDial: Internet dialer version 1.61
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","pinternet.interkom.de"
AT+CGDCONT=1,"IP","pinternet.interkom.de"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!}!} }=}#}%B#}%}(}"}'}"}!}$}%\}"}&} } } } }%}&&[0f]}>}2PI~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sat Jan 12 20:00:10 2013
--> Pid of pppd: 4770
--> Using interface ppp0
--> Disconnecting at Sat Jan 12 20:00:11 2013
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds



During my first experiments and now, allways in /var/log/messages and ~syslog the same quotes:

messages quote:
      Quote:
Jan 12 18:32:03 aptosidbox kernel: [ 315.505992] usb 2-1.4: Product: F5521gw
Jan 12 18:32:03 aptosidbox kernel: [ 315.505997] usb 2-1.4: Manufacturer: Lenovo
Jan 12 18:32:03 aptosidbox kernel: [ 315.506002] usb 2-1.4: SerialNumber: 25CBE64DFCAE5820
Jan 12 18:32:03 aptosidbox kernel: [ 315.537906] cdc_acm 2-1.4:1.1: ttyACM0: USB ACM device
Jan 12 18:32:03 aptosidbox kernel: [ 315.541026] cdc_acm 2-1.4:1.3: ttyACM1: USB ACM device
Jan 12 18:32:03 aptosidbox kernel: [ 315.548909] cdc_wdm 2-1.4:1.5: cdc-wdm0: USB WDM device
Jan 12 18:32:03 aptosidbox kernel: [ 315.564579] usb 2-1.4: MAC-Address: 02:80:37:ec:02:00
Jan 12 18:32:03 aptosidbox kernel: [ 315.564746] cdc_ncm 2-1.4:1.6: wwan0: register 'cdc_ncm' at usb-0000:00:1d.0-1.4, Mobile Broadband Network Device, 02:80:37:ec:02:00
Jan 12 18:32:03 aptosidbox kernel: [ 315.565260] cdc_wdm 2-1.4:1.8: cdc-wdm1: USB WDM device
Jan 12 18:32:03 aptosidbox kernel: [ 315.565522] cdc_acm 2-1.4:1.9: ttyACM2: USB ACM device
Jan 12 18:32:03 aptosidbox kernel: [ 315.685242] IPv6: ADDRCONF(NETDEV_UP): wwan0: link is not ready
Jan 12 18:32:03 aptosidbox kernel: [ 315.690434] cdc_ncm: wwan0: network connection: disconnected


and

      Quote:
Jan 12 19:31:48 aptosidbox pppd[4502]: pppd 2.4.5 started by root, uid 0
Jan 12 19:31:48 aptosidbox kernel: [ 3899.799008] PPP generic driver version 2.4.2
Jan 12 19:31:48 aptosidbox pppd[4502]: Using interface ppp0
Jan 12 19:31:48 aptosidbox pppd[4502]: Connect: ppp0 <--> /dev/ttyACM0
Jan 12 19:31:48 aptosidbox pppd[4502]: CHAP authentication succeeded: Congratulations!
Jan 12 19:31:48 aptosidbox pppd[4502]: CHAP authentication succeeded
Jan 12 19:31:48 aptosidbox kernel: [ 3899.844511] PPP BSD Compression module registered
Jan 12 19:31:48 aptosidbox kernel: [ 3899.876018] PPP Deflate Compression module registered
Jan 12 19:31:48 aptosidbox pppd[4502]: LCP terminated by peer
Jan 12 19:31:48 aptosidbox pppd[4502]: Modem hangup
Jan 12 19:31:48 aptosidbox pppd[4502]: Connection terminated.
Jan 12 19:31:48 aptosidbox pppd[4502]: Exit.



I understood „LCP terminated by peer“ means a disconnect by provider?


syslog quote:
      Quote:
Jan 12 18:32:03 aptosidbox kernel: [ 315.232123] usb 2-1.4: USB disconnect, device number 3
Jan 12 18:32:03 aptosidbox kernel: [ 315.232525] cdc_ncm 2-1.4:1.6: wwan0: unregister 'cdc_ncm' usb-0000:00:1d.0-1.4, Mobile Broadband Network Device


and

      Quote:
Jan 12 18:32:03 aptosidbox kernel: [ 315.564746] cdc_ncm 2-1.4:1.6: wwan0: register 'cdc_ncm' at usb-0000:00:1d.0-1.4, Mobile Broadband Network Device, 02:80:37:ec:02:00
Jan 12 18:32:03 aptosidbox kernel: [ 315.565260] cdc_wdm 2-1.4:1.8: cdc-wdm1: USB WDM device



First it is „unregister“ then „register“.


It's not the first time, I am configureted an umts-connection on a laptop,but always mit umts-sticks; but now I've got not more ideas.
The first time after nearly 6 years Sidux/Aptosid

Can it be a hardware-conflikt?

Thanks
wkauz
 
 View user's profile Send private message  
Reply with quote Back to top
DonKultOffline
Post subject:   PostPosted: 21.01.2013, 12:20
Team Member


Joined: 2010-09-02
Posts: 481

Status: Offline
Are you sure the phone number is correct? (http://wiki.openmoko.org/wiki/T-Mobile_pppd_scripts suggests this can be a course for this error message)

I have a blau-prepaid card (blau uses e-plus infrastructure) lying around here somewhere (not used in the last few months) and the working configuration has a different phone number ("*99***1#") than what this website claims (beside that username and password seem to be required for me, too).

Hardware issue might be, feel free to try it on another machine/operation system if you can, but if you get that far it shouldn't be one.

Just in case someone with a blau-card stumbles over this thread:
      Code:
[Dialer Defaults]
Init3 = AT+CGDCONT=1, "ip","internet.eplus.de"
Baud = 460800
Phone = *99***1#
Username = blau
Password = blau
Modem = /dev/gsmmodem
Stupid Mode = 1

is what worked for me.

(sry, my roundtrip time is extremely high currently because of a multitude of issues at home)

_________________
MfG. DonKult
"I never make stupid mistakes. Only very, very clever ones." ~ The Doctor
 
 View user's profile Send private message Visit poster's website  
Reply with quote Back to top
wkauzOffline
Post subject:   PostPosted: 25.01.2013, 17:31



Joined: 2010-09-13
Posts: 16
Location: Saarbrücken/Germany
Status: Offline
Hallo DontKult!
Thanks for your replay.

I used all possible Phone-Combinations and a lot different Configurations of wvdial.conf. after searches in the Web and the aptosid-manuel.
It's always the same result like before.
And when I use the command „dialer pin“ alone or in wvdial.conf on a advanced position, I get the message „Bad init string“. But the pin is right.
With W7 on the same maschine(T420) I have no problems.

Also I installed the „Laptop-mode-tools“ to blacklisting the F5521gw for autosuspend, because this can also make problems(Think-pad-wiki).

Now I gived it up.
For me it was a test, because in this year I go for 2 years to India and before, its important for me to collect experiences with my net-hardware and aptosid.
In Germany I don't really need an umts-connection and in India the Situation is different than here.
So I will see, how it goes there.

Thanks for your efforts.

wkauz
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 12 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio